Δευτέρα, 14 Μαρτίου 2011

Θέμα 3ο : Επαναληπτικές απολυτήριες εξετάσεις ενιαίου λυκείου 2004

Σε κάποια εξεταστική δοκιμασία κάθε γραπτό αξιολογείται
αρχικά από δύο βαθμολογητές και υπάρχει περίπτωση το
γραπτό να χρειάζεται αναβαθμολόγηση από τρίτο
βαθμολογητή. Στην περίπτωση αναβαθμολόγησης ο τελικός
βαθμός υπολογίζεται ως εξής:
i. Αν ο βαθμός του τρίτου βαθμολογητή είναι ίσος με το
   μέσο όρο (ΜΟ) των βαθμών των δύο πρώτων
   βαθμολογητών, τότε ο τελικός βαθμός είναι ο ΜΟ.
ii. Αν ο βαθμός του τρίτου βαθμολογητή είναι μικρότερος
    από το μικρότερο βαθμό (ΜΙΝ) των δύο πρώτων
    βαθμολογητών, τότε ο τελικός βαθμός είναι ο ΜΙΝ.
iii. Διαφορετικά, ο τελικός βαθμός είναι ο μέσος όρος του
    βαθμού του τρίτου βαθμολογητή με τον πλησιέστερο
    προς αυτόν βαθμό των δύο πρώτων βαθμολογητών.
Να αναπτύξετε αλγόριθμο υπολογισμού του τελικού βαθμού
ενός γραπτού με αναβαθμολόγηση, ο οποίος:
α. να διαβάζει τους βαθμούς του πρώτου, του δεύτερου και
    του τρίτου βαθμολογητή ενός γραπτού.
                                                                        Μονάδες 2
β. να υπολογίζει και να εκτυπώνει το μεγαλύτερο (ΜΑΧ)
    και το μικρότερο (ΜΙΝ) από τους βαθμούς του πρώτου
    και του δεύτερου βαθμολογητή.
                                                                       Μονάδες 6
γ. να υπολογίζει και να εκτυπώνει τον τελικό βαθμό του
    γραπτού σύμφωνα με την παραπάνω διαδικασία.
                                                                     Μονάδες 12
Παρατήρηση: Θεωρήστε ότι και οι τρεις βαθμοί είναι
θετικοί ακέραιοι αριθμοί και δεν απαιτείται έλεγχος
των δεδομένων.

Λύση

    Αλγόριθμος Θ3_ΕπανΕν2004
    Διάβασε Β1, Β2, Β3
    ΜΟ <-- (Β1+Β2)/2
    Αν Β1 < Β2 τότε
         ΜΙΝ <-- Β1
         ΜΑΧ <-- Β2
    αλλιώς
         ΜΙΝ <-- Β2
         ΜΑΧ <-- Β1
    Τέλος_αν
    Εμφάνισε ΜΙΝ, ΜΑΧ
    Αν Β3 = ΜΟ τότε
         Τελ <-- ΜΟ
    αλλιώς_αν Β3 < ΜΙΝ τότε
         Τελ <-- ΜΙΝ
    αλλιώς
         Αν Α_Τ(Β3-Β1) < Α_Τ(Β3-Β2) τότε
                Τελ <-- (Β1+Β3)/2
         αλλιώς
                Τελ <-- (Β2+Β3)/2
         Τέλος_αν
    Τέλος_αν
    Εμφάνισε Τελ
    Τέλος Θ3_ΕπανΕν2004

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου