Παρασκευή, 27 Σεπτεμβρίου 2013

Συνδιαστική

Δίνονται οι ακέραιες τιμές Α, Β με Α < Β. Γράψτε 
αλγόριθμο που εμφανίζει τις τετράδες
Χ,Υ,Ζ, Κ από το ακέραιο διάστημα τιμών
[1, 200] που έχουν άθροισμα μεγαλύτερο από  
την τιμή 2*Α+Β.

Λύση

Αλγόριθμος Συνδ
Για  Χ από 1 μέχρι 200
    Για  Υ από μέχρι 200
        Για  Ζ από μέχρι 200
            Για  Κ από μέχρι 200
                 Αν (Χ+Υ+Ζ+Κ) > 2*Α+Β τότε
                      Εμφάνισε Χ, Υ, Ζ, Κ
                 Τέλος_αν
            Τέλος_επανάληψης
        Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Συνδ

Έλεγχος ιδιότητας ανά στήλη


Μέγιστο-ελάχιστο-κύρια διαγώνιος


Συγγραφή διαδικασίας


Συγγραφή συνάρτησης


Παρασκευή, 13 Σεπτεμβρίου 2013

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή επιλογή.
1. Ο αλγόριθμος
    α. είναι μια μορφή δεδομένων
    β. μπορεί να μην έχει έξοδο
    γ. υλοποιεί μια επεξεργασία δεδομένων
    δ. διατυπώνεται σε ΓΛΩΣΣΑ

2. Μια συνάρτηση
    α. μπορεί να κάνει οποιαδήποτε λειτουργία
    β. μπορεί να εκτυπώνει αποτελέσματα
    γ. να διαβάζει δεδομένα
    δ. υπολογίζει και επιστρέφει ένα μόνο
        αποτέλεσμα
 
3. Το λογικό διάγραμμα
    α. είναι ένας τρόπος αναπαράστασης αλγορίθμων
    β. είναι μια γλώσσα προγραμματισμού
    γ. δεν μπορεί να χρησιμοποιηθεί για την
        αναπαράσταση αλγορίθμων ακολουθιακής
       δομής
    δ. είναι άμεσα εκτελέσιμο στον υπολογιστή

4. Το πρόγραμμα
    α. εκτελείται στον υπολογιστή
    β. είναι γραμμένο σε ψευδογλώσσα
    γ. γράφεται στα Αγγλικά
    δ. είναι μια ακολουθία από 0 και 1

5. Μια δομή επιλογής
    α. επιτρέπει την επανάληψη μιας ομάδας
        εντολών
    β. επιτρέπει τη διενέργεια ενός ελέγχου πριν
        από την εκτέλεση κάποιων ενεργειών
    γ. ξεκινάει με τη δεσμευμένη λέξη
        Α_N
    δ. τελειώνει με τη δεσμευμένη λέξη
        ΑΛΛΙΩΣ

Απαντήσεις

1. γ
2. δ
3. α
4. α
5. β

Πέμπτη, 12 Σεπτεμβρίου 2013

Πίνακας αντιστοίχησης

Δίνονται οι  παρακάτω μεταβλητές
1. Επωνυμία δρόμου
2. Πλήθος επιβατών λεωφορείου
3. Ποσοστό ανδρών σε ένα σύλλογο
4. Αποτέλεσμα μιας εξεταστικής
    διαδικασίας (επιτυχής ή ανεπιτυχής)
5. Μάρκα μιας συσκευής
και οι τύποι:
α. ΑΚΕΡΑΙΕΣ
β. ΠΡΑΓΜΑΤΙΚΕΣ
γ. ΛΟΓΙΚΕΣ
δ. ΧΑΡΑΚΤΗΡΕΣ
Γράψτε τον αριθμό και δίπλα το κατάλληλο γράμμα
ώστε να προκύψει η σωστή αντιστοίχηση.

Απαντήσεις

1. δ
2. α
3. β
4. γ
5. δ

Τρίτη, 10 Σεπτεμβρίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Τα ___________ δεδομένα γίνονται αντιληπτά από
    έναν εξωτερικό παρατηρητή με μια από τις πέντε
    ανθρώπινες αισθήσεις.
2. Το ___________ κείμενο είναι μια μορφή
    αναπαράστασης αλγορίθμων.
3. Το ΚΑΙ είναι ένας _________ τελεστής.
4. Η ________ των συγκριτικών τελεστών είναι
    μικρότερη αυτής των αριθμητικών.
5. Κάθε υποπρόγραμμα τελειώνει με τη
    δεσμευμένη λέξη _______ ή ________.


Απαντήσεις

1. δεδομένα
2. ελεύθερο
3. λογικός
4 ιεραρχία ή προτεραιότητα
5. ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ, ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Διόρθωση λανθασμένων προτάσεων και επαναδιατύπωσή τους

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Η δομή επιλογής επιτρέπει την επανάληψη μιας
    ομάδας εντολών.
2. Η πράξη div δίνει αποτέλεσμα πραγματικού τύπου.
3. Ένα πρόγραμμα πρέπει να έχει τουλάχιστον μια
    μεταβλητή.
4. Ο τμηματικός προγραμματισμός είναι μια
    τεχνική διάσπασης των προβλημάτων σε
    υποπροβλήματα.
5. Ο πίνακας εμπεριέχει μια ομάδα δεδομένων.



Απαντήσεις

1. Η δομή επανάληψης επιτρέπει την επανάληψη μιας
    ομάδας εντολών.
2. Η πράξη div δίνει αποτέλεσμα ακεραίου τύπου.
3. Ένα πρόγραμμα μπορεί να μην έχει καθόλου
    μεταβλητές.
4. Ο τμηματικός προγραμματισμός είναι μια
    τεχνική διάσπασης των προγραμμάτων σε
    υποπρογράμματα.
5. Ο πίνακας εμπεριέχει μια ομάδα δεδομένων ίδιου τύπου.

Παρασκευή, 6 Σεπτεμβρίου 2013

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Η ταχύτητα είναι αλγοριθμικό κριτήριο.
2. Ο αλγόριθμος γράφεται στη γλώσσα προγραμματισμού
    PASCAL.
3. Το συνηθέστερο μέσο διατύπωσης των προβλημάτων
    είναι ο λόγος.
4. ΟΧΙ ΚΑΙ Υ) = ΟΧΙ Χ ΚΑΙ ΟΧΙ Υ
5. Ο πίνακας αλήθειας της λογικής παράστασης
          ΟΧΙ Ή Υ Ή Ζ)
    περιλαμβάνει 8 συνδυασμούς τιμών για τις
    μεταβλητές Χ, Υ, Ζ.


Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Λ