Πέμπτη, 27 Σεπτεμβρίου 2012

Ερωτήσεις σωστού λάθους

Αν Ν θετικός ακέραιος, ποιες από τις παρακάτω σχέσεις είναι
σωστές και ποιες λάθος;
1. (4*Ν+8) mod 4 = 0
2. (4*Ν+8) div (4*N+9) = 0
3. (2^2 >= 2+3) = ΑΛΗΘΗΣ
4. ( 'ΚΑΛΗΜΕΡΑ' <=  'ΚΑΛΗΣΠΕΡΑ' ) = ΨΕΥΔΗΣ
5.  (Τ_Ρ(Α_Τ(Χ)) >= 0 ) = ΑΛΗΘΗΣ



Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Λ
5. Σ

Τετάρτη, 26 Σεπτεμβρίου 2012

Πίνακας δεδομένων - ζητουμένων


Σ’ ένα χωριό κατοικούν 200 κάτοικοι. Αν τα 
παιδιά αποτελούν το 20% του πληθυσμού 
των ανδρών και οι γυναίκες είναι κατά 46 
περισσότερες από τους άνδρες, πόσοι 
άνδρες, γυναίκες και παιδιά κατοικούν 
στο χωριό αυτό;
1.     Κατασκευάστε πίνακα 
     δεδομένων - ζητούμενων.
2.     Μορφοποιήστε με μαθηματικό 
     τρόπο το πρόβλημα.

Λύση

1.

   Δεδομένα     * Το συνολικό πλήθος των 
                           κατοίκων είναι 200
                        * Τα παιδιά αποτελούν  
                           το 20% του πληθυ-
                           σμού των ανδρών
                        * Οι γυναίκες είναι κατά 
                           46 περισσότερες από 
                           τους άνδρες
  Ζητούμενα    * Πλήθος ανδρών
                        * Πλήθος γυναικών
                        * Πλήθος παιδιών

2. 
       Ας συμβολίσουμε με 
            Ανδ : το πλήθος των ανδρών
            Γυν : το πλήθος των γυναικών
            Παιδ: το πλήθος των παιδιών
       Ισχύουν οι σχέσεις:
            Ανδ+Γυν+Παιδ = 200
            Παιδ = Ανδ*20/100
            Γυν = Ανδ+46





Κυριακή, 23 Σεπτεμβρίου 2012

Απάντηση σε ερώτηση

Γράψτε αλγόριθμο ο οποίος:
α) διαβάζει δυάδες ακεραίων αριθμών (η είσοδος δεδομένων
    ολοκληρώνεται μόλις δοθεί η απάντηση 'ΟΧΙ' στην
     υποβαλλόμενη προς το χρήστη ερώτηση
      'Ολοκληρώθηκε η είσοδος;'),
β) υπολογίζει και εμφανίζει:
    * το άθροισμα κάθε δυάδας,
    * το ποσοστό (%) των δυάδων που τα μέλη τους διέφεραν
       περισσότερο από 20,
    * το πλήθος των δυάδων με ομόσημα μέλη.

Λύση

     Αλγόριθμος Δυάδες
     φ20 <-- 0
     πληθ <-- 0
     ομο <-- 0
     Αρχή_επανάληψης
           Διάβασε α, β
           αθρ <-- α+β
           πληθ <-- πληθ+1
           Εμφάνισε αθρ
           Αν α*β > 0 τότε
                ομο <-- ομο+1
           Τέλος_αν
           Αν Α_Τ(α-β) > 20 τότε
                φ20 <-- φ20+1
           Τέλος_αν
           Εμφάνισε 'Ολοκληρώθηκε η είσοδος;'
           Διάβασε Απ
     Μέχρις_ότου Απ = 'ΟΧΙ'
     ποσ <-- 100*φ20/Πληθ
     Εμφάνισε ομο, ποσ
     Τέλος Δυάδες

Σάββατο, 22 Σεπτεμβρίου 2012

Φρουρός

Γράψτε αλγόριθμο ο οποίος:
α) διαβάζει τριάδες ακεραίων αριθμών (η είσοδος δεδομένων
    ολοκληρώνεται μόλις κάποια από τις τιμές εισόδου είναι μη
    θετική),
β) υπολογίζει και εμφανίζει πόσες από τις παραπάνω τριάδες
    είναι Πυθαγόρειες.
Παρατήρηση : Πυθαγόρεια είναι μια τριάδα αριθμών που
έχει την ιδιότητα το τετράγωνο του ενός αριθμού να είναι
ίσο με το άθροισμα των τετραγώνων των δύο άλλων.

Λύση

    Αλγόριθμος Πυθαγορ
    πληθ <-- 0
    Αρχή_επανάληψης
         Διάβασε α, β, γ
         Αν (α > 0) ΚΑΙ (β > 0) ΚΑΙ (γ > 0) τότε
               Αν (α^2 = β^2+γ^2) Ή (β^2 = α^2+γ^2) Ή
                    (γ^2 = α^2+β^2) τότε
                      πληθ <-- πληθ+1
               Τέλος_αν
         Τέλος_αν
    Μέχρις_ότου (α <= 0) Ή (β <= 0) Ή (γ <= 0)
    Εμφάνισε πληθ
    Τέλος Πυθαγορ

Τρίτη, 18 Σεπτεμβρίου 2012

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Ο αλγόριθμος μπορεί να μην βγάζει κανένα αποτέλεσμα ως
     έξοδο.
2. Οι μεταβλητές ενός προγράμματος έχουν ένα μοναδικό
    τύπο δεδομένων που δηλώνεται στο τμήμα δήλωσης
    των μεταβλητών.
3. Οι εντολές εκχώρησης και ΔΙΑΒΑΣΕ μπορούν να
    αλλάξουν το περιεχόμενο μιας μεταβλητής.
4. Τα υποπρογράμματα δεν μπορούν να αλλάξουν το
    περιεχόμενο των πραγματικών παραμέτρων.
5. Οι συναρτήσεις είναι αναπόσπαστο στοιχείο ενός
    προγράμματος.
   

Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Λ
5. Λ


Κυριακή, 16 Σεπτεμβρίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που:
α) διαβάζει τους τίτλους και το πλήθος των σελίδων 130
    μυθιστορημάτων,
β) υπολογίζει και εμφανίζει:
    * πόσα βιβλία έχουν περισσότερες από 330 σελίδες,
    * τον τίτλο του βιβλίου με τις λιγότερες σελίδες.

Λύση

    Αλγόριθμος Μυθ
    φ330 <-- 0
    μικ <-- 99999
    Για κ από 1 μέχρι 130
         Διάβασε τιτλ
         Διάβασε σελ
         Αν σελ > 330 τότε
             φ330 <-- φ330+1
         Τέλος_αν
         Αν σελ < μικ τότε
             μικ <-- σελ
             τιτλμικ <-- τιτλ
         Τέλος_αν
    Τέλος_επανάληψης
    Εμφάνισε τιτλμικ, φ330
    Τέλος Μυθ

Πέμπτη, 13 Σεπτεμβρίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει
τα έτη γέννησης των 500 μαθητών ενός γυμνασίου, υπολογίζει
και εμφανίζει:
α) το μέσο όρο ηλικίας τους,
β) τον αύξοντα αριθμό (1-500) του γηραιότερου μαθητή.

Λύση

      Αλγόριθμος Μαθητές
      σ <-- 0
      Μικ <-- 3001
      Για κ από 1 μέχρι 500
           Διάβασε Έτος
           Αν Έτος < Μικ τότε
                 Μικ <-- Έτος
                 ΑΑΓηρ <-- κ
           Τέλος_αν
           σ <-- σ+(2012-Έτος)
      Τέλος_επανάληψης
      μο <-- σ/500
      Εμφάνισε μο, ΑΑΓηρ
      Τέλος Μαθητές

Φρουρός

Γράψτε αλγόριθμο που διαβάζει την επωνυμία και το πλήθος των
ασφαλισμένων κάποιων ασφαλιστικών ταμείων (η είσοδος
δεδομένων ολοκληρώνεται μόλις δοθεί ως επωνυμία το κενό
διάστημα ή ως πλήθος ασφαλισμένων μια μη θετική τιμή),
υπολογίζει και εμφανίζει:
α) την επωνυμία του ασφαλιστικού ταμείου με τους
    περισσότερους ασφαλισμένους,
β) το ποσοστό (%) των ασφαλιστικών ταμείων που είχαν
    τουλάχιστον 20000 ασφαλισμένους.

Λύση

    Αλγόριθμος Ταμεία
    φ20 <-- 0
    πληθ <-- 0
    Μεγ <-- -100
    Αρχή_επανάληψης
            Διάβασε επ
            Διάβασε ασφ
            Αν (επ < > '  ') ΚΑΙ (ασφ > 0) τότε
                 πληθ <-- πληθ+1
                 Αν ασφ >= 20000 τότε
                      φ20 <-- φ20+1
                 Τέλος_αν
                 Αν ασφ > Μεγ τότε
                      Μεγ <-- ασφ
                      επΜεγ <-- επ
                 Τέλος_αν
            Τέλος_αν
    Μέχρις_ότου (επ = '  ') Ή (ασφ <= 0)
    Αν πληθ > 0 τότε
         ποσ20 <-- 100*φ20/πληθ
         Εμφάνισε ποσ20, επΜεγ
    αλλιώς
         Εμφάνισε 'Δε δόθηκαν δεδομένα'
    Τέλος_αν
    Τέλος Ταμεία

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Η επίλυση της εξίσωσης  αΧ=β είναι αδόμητο πρόβλημα.
2. Η συνάρτηση Τ_Ρ επιστρέφει αποτέλεσμα ακεραίου τύπου.
3. Η αποτελεσματικότητα είναι ένα αλγοριθμικό κριτήριο.
4. Μια δυναμική δομή δεδομένων αποθηκεύει τους κόμβους της
    σε μη συνεχόμενες θέσεις μνήμης.
5. Η λέξη ανθρώπων ανήκει στο τυπολογικό της ελληνικής
    γλώσσας.


Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Σ
5. Σ

Τετάρτη, 12 Σεπτεμβρίου 2012

Απάντηση σε ερώτηση+αναγωγή στη μονάδα

Γράψτε αλγόριθμο που :
α) διαβάζει τις τιμές πώλησης και το πλήθος των ετικετών
    κάποιων συσκευασιών (η είσοδος δεδομένων ολοκληρώνεται
    μόλις δοθεί η απάντηση 'ΟΧΙ' στην υποβαλλόμενη προς το
    χρήστη ερώτηση 'Υπάρχει άλλη συσκευασία;'),
β) υπολογίζει και εμφανίζει τον αύξοντα αριθμό της πιο
    συμφέρουσας για έναν πελάτη συσκευασίας.
Παρατήρηση: Καμιά συσκευασία δε στοίχιζε περισσότερα
από 5 ευρώ.

Λύση

    Αλγόριθμος Ασκ
    Μικ <-- 6
    Πληθ <-- 0
    Αρχή_επανάληψης
         Διάβασε Τιμ, Ετικ
         Πληθ <-- Πληθ+1
         ΤιμΕτικ <-- Τιμ/Ετικ
         Αν ΤιμΕτικ < Μικ τότε
              Μικ <-- ΤιμΕτικ
              ΑΑΜικ <-- Πληθ
         Τέλος_αν
         Εμφάνισε 'Υπάρχει άλλη συσκευασία;'
         Διάβασε Απ
    Μέχρις_ότου Απ = 'ΟΧΙ'
    Εμφάνισε ΑΑΜικ
    Τέλος Ασκ
    

Δευτέρα, 10 Σεπτεμβρίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει τις χωρητικότητες (σε λίτρα) 25
δεξαμενών και υπολογίζει:
α) τη μέση χωρητικότητα τους,
β) τον αύξοντα αριθμό (1-25) της δεξαμενής με τη μικρότερη
    χωρητικότητα,
γ) πόσες δεξαμενές είχαν χωρητικότητα που ξεπερνούσε
    τα 10000 λίτρα.
Παρατήρηση : Καμιά δεξαμενή δεν είχε χωρητικότητα
μεγαλύτερη από 20000 λίτρα.

Απάντηση

     Αλγόριθμος Δεξαμενές
     Μικ <-- 20001
     σ <-- 0
     φ <-- 0
     Για κ από 1 μέχρι 25
          Διάβασε χωρ
          σ <-- σ+χωρ
          Αν χωρ < Μικ τότε
               Μικ <-- χωρ
               ΑΑΜικ <-- κ
          Τέλος_αν
          Αν χωρ > 10000 τότε
               φ <-- φ+1
          Τέλος_αν
     Τέλος_επανάληψης
     μο <-- σ/25
     Αποτελέσματα // μο, ΑΑΜικ, φ //
     Τέλος Δεξαμενές

Σάββατο, 8 Σεπτεμβρίου 2012

Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που:
α) διαβάζει το πλήθος  των μυθιστορημάτων που διάβασαν
     μέσα στο χρόνο κάποιοι μαθητές (η είσοδος δεδομένων
    ολοκληρώνεται μόλις δοθεί η απάντηση 'Ν' στην
    υποβαλλόμενη προς το χρήστη ερώτηση 'Υπάρχει άλλος
    μαθητής;'),
β) υπολογίζει και εμφανίζει:
    * το ποσοστό (%) των μαθητών που διάβασαν τουλάχιστον
       10 μυθιστορήματα,
    * τον αύξοντα αριθμό του μαθητή που διάβασε τα λιγότερα.
Παρατήρηση
Θεωρείστε ότι κανένας μαθητής δε διάβασε περισσότερα από
50 μυθιστορήματα.

Λύση

    Αλγόριθμος βιβλία
    πληθ <-- 0
    φ <-- 0
    μικ <-- 51
    Αρχή_επανάληψης
         Διάβασε αρβ
         πληθ <-- πληθ+1
         Αν αρβ >= 10 τότε
              φ <-- φ+1
         Τέλος_αν
         Αν αρβ < μικ τότε
              μικ <-- αρβ
              ααμικ <-- πληθ
         Τέλος_αν
         Εμφάνισε 'Υπάρχει άλλος μαθητής;'
         Διάβασε απ
    Μέχρις_ότου απ = 'Ν'
    ποσ10 <-- 100*φ/πληθ
    Εμφάνισε ποσ10, ααμικ
    Τέλος βιβλία

Φρουρός

Γράψτε αλγόριθμο που:
α) διαβάζει τις εβδομαδιαίες ώρες διδασκαλίας που παρακολουθούν
     κάποιοι μαθητές στα Αγγλικά (η είσοδος τερματίζεται μόλις
     δοθεί μια αρνητική τιμή εισόδου).
β) υπολογίζει το μέσο όρο εβδομαδιαίων ωρών διδασκαλίας
    των Αγγλικών ανά μαθητή.

Λύση

    Αλγόριθμος Αγγλ
    σ <-- 0
    πληθ <-- 0
    Αρχή_επανάληψης
        Διάβασε Ω
        Αν Ω >= 0 τότε
              σ <-- σ+Ω
              πληθ <-- πληθ+1
        Τέλος_αν
    Μέχρις_ότου Ω < 0
    Αν πληθ > 0 τότε
        μο <-- σ/πληθ
        Εμφάνισε μο
    αλλιώς 
        Εμφάνισε 'Δε δόθηκαν δεδομένα!'
    Τέλος_αν
    Τέλος Αγγλ

Τετάρτη, 5 Σεπτεμβρίου 2012

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και επαναδιατυπώστε
τις με σωστό τρόπο.
1. Ο αλγόριθμος ολοκληρώνεται μετά από περιορισμένο αριθμό
    βημάτων.
2. Το πρόβλημα του έτους 2000 είχε να κάνει με τον τρόπο
     αποθήκευσης της ώρας στους παλιότερους υπολογιστές.
3.  Οι εγγραφές είναι δομές δεδομένων δευτερεύουσας μνήμης.
4.  Μια από τις σκοπιές που εξετάζει η Πληροφορική τα δεδομένα
     είναι και αυτή των ψευδογλωσσών.
5.  Οι μεταβλητές έχουν σταθερό περιεχόμενο.



Απαντήσεις

1. Ο αλγόριθμος ολοκληρώνεται μετά από πεπερασμένο αριθμό
    βημάτων.

2. Το πρόβλημα του έτους 2000 είχε να κάνει με τον τρόπο
     αποθήκευσης της ημερομηνίας στους παλιότερους υπολογιστές.
3.  Οι εγγραφές είναι δομές δεδομένων κύριας μνήμης.

4.  Μια από τις σκοπιές που εξετάζει η Πληροφορική τα δεδομένα
     είναι και αυτή των γλωσσών προγραμματισμού.
5.  Οι μεταβλητές έχουν σταθερό τύπο δεδομένων.

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Η πράξη div μπορεί να εφαρμοστεί μόνο σε ορίσματα ακεραίου
    τύπου.
2. Ο τελεστής >= μπορεί να εφαρμοστεί και πάνω σε ορίσματα
    λογικού τύπου.
3. Ο πίνακας είναι μια συλλογή στοιχείων ακεραίου τύπου.
4. Μια συνάρτηση μπορεί να επιστρέψει ως αποτέλεσμά της έναν
    ολόκληρο πίνακα.
5. Ο ορισμός μιας διαδικασίας τελειώνει με τη δεσμευμένη
    λέξη ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ.

Απαντήσεις

1. Σ
2. Λ
3. Λ
4. Λ
5. Σ