Σάββατο, 22 Σεπτεμβρίου 2012

Φρουρός

Γράψτε αλγόριθμο ο οποίος:
α) διαβάζει τριάδες ακεραίων αριθμών (η είσοδος δεδομένων
    ολοκληρώνεται μόλις κάποια από τις τιμές εισόδου είναι μη
    θετική),
β) υπολογίζει και εμφανίζει πόσες από τις παραπάνω τριάδες
    είναι Πυθαγόρειες.
Παρατήρηση : Πυθαγόρεια είναι μια τριάδα αριθμών που
έχει την ιδιότητα το τετράγωνο του ενός αριθμού να είναι
ίσο με το άθροισμα των τετραγώνων των δύο άλλων.

Λύση

    Αλγόριθμος Πυθαγορ
    πληθ <-- 0
    Αρχή_επανάληψης
         Διάβασε α, β, γ
         Αν (α > 0) ΚΑΙ (β > 0) ΚΑΙ (γ > 0) τότε
               Αν (α^2 = β^2+γ^2) Ή (β^2 = α^2+γ^2) Ή
                    (γ^2 = α^2+β^2) τότε
                      πληθ <-- πληθ+1
               Τέλος_αν
         Τέλος_αν
    Μέχρις_ότου (α <= 0) Ή (β <= 0) Ή (γ <= 0)
    Εμφάνισε πληθ
    Τέλος Πυθαγορ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου