Πέμπτη, 13 Σεπτεμβρίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει
τα έτη γέννησης των 500 μαθητών ενός γυμνασίου, υπολογίζει
και εμφανίζει:
α) το μέσο όρο ηλικίας τους,
β) τον αύξοντα αριθμό (1-500) του γηραιότερου μαθητή.

Λύση

      Αλγόριθμος Μαθητές
      σ <-- 0
      Μικ <-- 3001
      Για κ από 1 μέχρι 500
           Διάβασε Έτος
           Αν Έτος < Μικ τότε
                 Μικ <-- Έτος
                 ΑΑΓηρ <-- κ
           Τέλος_αν
           σ <-- σ+(2012-Έτος)
      Τέλος_επανάληψης
      μο <-- σ/500
      Εμφάνισε μο, ΑΑΓηρ
      Τέλος Μαθητές

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου