Κυριακή, 23 Σεπτεμβρίου 2012

Απάντηση σε ερώτηση

Γράψτε αλγόριθμο ο οποίος:
α) διαβάζει δυάδες ακεραίων αριθμών (η είσοδος δεδομένων
    ολοκληρώνεται μόλις δοθεί η απάντηση 'ΟΧΙ' στην
     υποβαλλόμενη προς το χρήστη ερώτηση
      'Ολοκληρώθηκε η είσοδος;'),
β) υπολογίζει και εμφανίζει:
    * το άθροισμα κάθε δυάδας,
    * το ποσοστό (%) των δυάδων που τα μέλη τους διέφεραν
       περισσότερο από 20,
    * το πλήθος των δυάδων με ομόσημα μέλη.

Λύση

     Αλγόριθμος Δυάδες
     φ20 <-- 0
     πληθ <-- 0
     ομο <-- 0
     Αρχή_επανάληψης
           Διάβασε α, β
           αθρ <-- α+β
           πληθ <-- πληθ+1
           Εμφάνισε αθρ
           Αν α*β > 0 τότε
                ομο <-- ομο+1
           Τέλος_αν
           Αν Α_Τ(α-β) > 20 τότε
                φ20 <-- φ20+1
           Τέλος_αν
           Εμφάνισε 'Ολοκληρώθηκε η είσοδος;'
           Διάβασε Απ
     Μέχρις_ότου Απ = 'ΟΧΙ'
     ποσ <-- 100*φ20/Πληθ
     Εμφάνισε ομο, ποσ
     Τέλος Δυάδες

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου