Δευτέρα, 10 Σεπτεμβρίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει τις χωρητικότητες (σε λίτρα) 25
δεξαμενών και υπολογίζει:
α) τη μέση χωρητικότητα τους,
β) τον αύξοντα αριθμό (1-25) της δεξαμενής με τη μικρότερη
    χωρητικότητα,
γ) πόσες δεξαμενές είχαν χωρητικότητα που ξεπερνούσε
    τα 10000 λίτρα.
Παρατήρηση : Καμιά δεξαμενή δεν είχε χωρητικότητα
μεγαλύτερη από 20000 λίτρα.

Απάντηση

     Αλγόριθμος Δεξαμενές
     Μικ <-- 20001
     σ <-- 0
     φ <-- 0
     Για κ από 1 μέχρι 25
          Διάβασε χωρ
          σ <-- σ+χωρ
          Αν χωρ < Μικ τότε
               Μικ <-- χωρ
               ΑΑΜικ <-- κ
          Τέλος_αν
          Αν χωρ > 10000 τότε
               φ <-- φ+1
          Τέλος_αν
     Τέλος_επανάληψης
     μο <-- σ/25
     Αποτελέσματα // μο, ΑΑΜικ, φ //
     Τέλος Δεξαμενές

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου