Σάββατο, 8 Σεπτεμβρίου 2012

Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που:
α) διαβάζει το πλήθος  των μυθιστορημάτων που διάβασαν
     μέσα στο χρόνο κάποιοι μαθητές (η είσοδος δεδομένων
    ολοκληρώνεται μόλις δοθεί η απάντηση 'Ν' στην
    υποβαλλόμενη προς το χρήστη ερώτηση 'Υπάρχει άλλος
    μαθητής;'),
β) υπολογίζει και εμφανίζει:
    * το ποσοστό (%) των μαθητών που διάβασαν τουλάχιστον
       10 μυθιστορήματα,
    * τον αύξοντα αριθμό του μαθητή που διάβασε τα λιγότερα.
Παρατήρηση
Θεωρείστε ότι κανένας μαθητής δε διάβασε περισσότερα από
50 μυθιστορήματα.

Λύση

    Αλγόριθμος βιβλία
    πληθ <-- 0
    φ <-- 0
    μικ <-- 51
    Αρχή_επανάληψης
         Διάβασε αρβ
         πληθ <-- πληθ+1
         Αν αρβ >= 10 τότε
              φ <-- φ+1
         Τέλος_αν
         Αν αρβ < μικ τότε
              μικ <-- αρβ
              ααμικ <-- πληθ
         Τέλος_αν
         Εμφάνισε 'Υπάρχει άλλος μαθητής;'
         Διάβασε απ
    Μέχρις_ότου απ = 'Ν'
    ποσ10 <-- 100*φ/πληθ
    Εμφάνισε ποσ10, ααμικ
    Τέλος βιβλία

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου