Κυριακή, 16 Σεπτεμβρίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που:
α) διαβάζει τους τίτλους και το πλήθος των σελίδων 130
    μυθιστορημάτων,
β) υπολογίζει και εμφανίζει:
    * πόσα βιβλία έχουν περισσότερες από 330 σελίδες,
    * τον τίτλο του βιβλίου με τις λιγότερες σελίδες.

Λύση

    Αλγόριθμος Μυθ
    φ330 <-- 0
    μικ <-- 99999
    Για κ από 1 μέχρι 130
         Διάβασε τιτλ
         Διάβασε σελ
         Αν σελ > 330 τότε
             φ330 <-- φ330+1
         Τέλος_αν
         Αν σελ < μικ τότε
             μικ <-- σελ
             τιτλμικ <-- τιτλ
         Τέλος_αν
    Τέλος_επανάληψης
    Εμφάνισε τιτλμικ, φ330
    Τέλος Μυθ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου