Σάββατο, 8 Σεπτεμβρίου 2012

Φρουρός

Γράψτε αλγόριθμο που:
α) διαβάζει τις εβδομαδιαίες ώρες διδασκαλίας που παρακολουθούν
     κάποιοι μαθητές στα Αγγλικά (η είσοδος τερματίζεται μόλις
     δοθεί μια αρνητική τιμή εισόδου).
β) υπολογίζει το μέσο όρο εβδομαδιαίων ωρών διδασκαλίας
    των Αγγλικών ανά μαθητή.

Λύση

    Αλγόριθμος Αγγλ
    σ <-- 0
    πληθ <-- 0
    Αρχή_επανάληψης
        Διάβασε Ω
        Αν Ω >= 0 τότε
              σ <-- σ+Ω
              πληθ <-- πληθ+1
        Τέλος_αν
    Μέχρις_ότου Ω < 0
    Αν πληθ > 0 τότε
        μο <-- σ/πληθ
        Εμφάνισε μο
    αλλιώς 
        Εμφάνισε 'Δε δόθηκαν δεδομένα!'
    Τέλος_αν
    Τέλος Αγγλ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου