Πέμπτη, 13 Σεπτεμβρίου 2012

Φρουρός

Γράψτε αλγόριθμο που διαβάζει την επωνυμία και το πλήθος των
ασφαλισμένων κάποιων ασφαλιστικών ταμείων (η είσοδος
δεδομένων ολοκληρώνεται μόλις δοθεί ως επωνυμία το κενό
διάστημα ή ως πλήθος ασφαλισμένων μια μη θετική τιμή),
υπολογίζει και εμφανίζει:
α) την επωνυμία του ασφαλιστικού ταμείου με τους
    περισσότερους ασφαλισμένους,
β) το ποσοστό (%) των ασφαλιστικών ταμείων που είχαν
    τουλάχιστον 20000 ασφαλισμένους.

Λύση

    Αλγόριθμος Ταμεία
    φ20 <-- 0
    πληθ <-- 0
    Μεγ <-- -100
    Αρχή_επανάληψης
            Διάβασε επ
            Διάβασε ασφ
            Αν (επ < > '  ') ΚΑΙ (ασφ > 0) τότε
                 πληθ <-- πληθ+1
                 Αν ασφ >= 20000 τότε
                      φ20 <-- φ20+1
                 Τέλος_αν
                 Αν ασφ > Μεγ τότε
                      Μεγ <-- ασφ
                      επΜεγ <-- επ
                 Τέλος_αν
            Τέλος_αν
    Μέχρις_ότου (επ = '  ') Ή (ασφ <= 0)
    Αν πληθ > 0 τότε
         ποσ20 <-- 100*φ20/πληθ
         Εμφάνισε ποσ20, επΜεγ
    αλλιώς
         Εμφάνισε 'Δε δόθηκαν δεδομένα'
    Τέλος_αν
    Τέλος Ταμεία

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου