Παρασκευή, 27 Σεπτεμβρίου 2013

Συνδιαστική

Δίνονται οι ακέραιες τιμές Α, Β με Α < Β. Γράψτε 
αλγόριθμο που εμφανίζει τις τετράδες
Χ,Υ,Ζ, Κ από το ακέραιο διάστημα τιμών
[1, 200] που έχουν άθροισμα μεγαλύτερο από  
την τιμή 2*Α+Β.

Λύση

Αλγόριθμος Συνδ
Για  Χ από 1 μέχρι 200
    Για  Υ από μέχρι 200
        Για  Ζ από μέχρι 200
            Για  Κ από μέχρι 200
                 Αν (Χ+Υ+Ζ+Κ) > 2*Α+Β τότε
                      Εμφάνισε Χ, Υ, Ζ, Κ
                 Τέλος_αν
            Τέλος_επανάληψης
        Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Συνδ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου