Παρασκευή, 13 Δεκεμβρίου 2013

Επαναδιατύπωση

Θεωρείστε τον ακέραιο πίνακα Α[345].
Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
    Για κ από 1 μέχρι 100 με_βήμα 200
         Για λ από 200 μέχρι 50 με_βήμα -190
              Για μ από 30 μέχρι 60 με_βήμα 40
                     Εμφάνισε Α[κ]*Α[λ]+Α[μ]
              Τέλος_επανάληψης
         Τέλος_επανάληψης
    Τέλος_επανάληψης
   

Απάντηση
Η πρώτη Για εκτελείται μόνο για κ = 1
Η δεύτερη Για εκτελείται μόνο για λ = 200
Η τρίτη Για εκτελείται μόνο για μ = 30.
Άρα όλο το σύνολο των εντολών μπορεί να αντικατασταθεί
από την εντολή :
    Εμφάνισε Α[1]*Α[200]+Α[30]

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου