Σάββατο, 15 Οκτωβρίου 2011

Συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παραμέτρους μια γωνία Χ
και υπολογίζει το ημίτονο, το συνημίτονο, την εφαπτομένη και
τη συνεφαπτομένη της γωνίας αυτής. Αν δεν είναι εφικτός ο
υπολογισμός της εφαπτομένης ή της συνεφαπτομένης, να
εκχωρείται στις αντίστοιχες παραμέτρους αποτελέσματος η
τιμή -9999.9

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΤΡΙΓ(Χ, ΗΜΧ, ΣΥΝΧ, ΕΦΧ, ΣΦΧ)
     ΜΕΤΑΒΛΗΤΕΣ
           ΠΡΑΓΜΑΤΙΚΕΣ: Χ, ΗΜΧ, ΣΥΝΧ, ΕΦΧ, ΣΦΧ
     ΑΡΧΗ
           ΗΜΧ <-- ΗΜ(Χ)
           ΣΥΝΧ <-- ΣΥΝ(Χ)
           ΑΝ ΣΥΝΧ < > 0 ΤΟΤΕ           
                 ΕΦΧ <-- ΕΦ(Χ)
           ΑΛΛΙΩΣ
                 ΕΦΧ <-- -9999.9
           ΤΕΛΟΣ_ΑΝ
           ΑΝ ΗΜΧ < > 0 ΤΟΤΕ           
                 ΣΦΧ <-- 1/ΕΦΧ
           ΑΛΛΙΩΣ
                 ΣΦΧ <-- -9999.9
           ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου