Τρίτη, 11 Οκτωβρίου 2011

Επίτευξη στόχου

Θέλετε να μαζέψετε 1000 ευρώ προκειμένου να πάτε
καλοκαιρινές διακοπές. Για το σκοπό αυτό αποταμιεύετε
κάποιο χρηματικό ποσό κάθε μέρα. Γράψτε αλγόριθμο ο
οποίος:
α) διαβάζει το ποσό που αποταμιεύετε καθημερινά,
β) υπολογίζει και εμφανίζει:
    * πόσες ημέρες χρειάστηκαν για να πετύχετε το
       στόχο σας,
    * το πιθανό περίσσευμα χρημάτων αν υπάρχει.

Λύση

      Αλγόριθμος Κουμπαράς
      Ημέρες <-- 0
      Σύνολο <-- 0
      Όσο Σύνολο < 1000 επανάλαβε
            Διάβασε Ποσό
            Σύνολο <-- Σύνολο+Ποσό
            Ημέρες <-- Ημέρες+1
      Τέλος_επανάληψης
      Εμφάνισε Ημέρες
      Αν Σύνολο > 1000 τότε
            Εμφάνισε Σύνολο-1000
      αλλιώς
            Εμφάνισε 'Δεν υπάρχει περίσσευμα'
      Τέλος_αν
      Τέλος Κουμπαράς

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου