Τετάρτη, 13 Οκτωβρίου 2010

Άσκηση : επεξεργασία δοσμένου πλήθους δεδομένων (Για..από..μέχρι)

Σ' ένα γυμνάσιο λειτουργούν 16 τμήματα. Γράψτε αλγόριθμο που
διαβάζει το πλήθος των μαθητών κάθε τμήματος, υπολογίζει και
εμφανίζει:
α) το συνολικό πλήθος των μαθητών του γυμνασίου,
β) τον αύξοντα αριθμό (1-16) του τμήματος που είχε το μικρότερο
    πλήθος μαθητών,
γ) τον αύξοντα αριθμό (1-16) του τμήματος που είχε το μεγαλύτερο
    πλήθος μαθητών,
δ) πόσα τμήματα είχαν λιγότερους από 28 μαθητές.

Λύση

     Αλγόριθμος Γυμνάσιο
     Διάβασε Μαθ
     ΜΑΧ <-- Μαθ
     ΑΑΜΑΧ <-- 1
     ΜΙΝ <-- Μαθ
     ΑΑΜΙΝ <-- 1
     Πληθ <-- Μαθ
     Αν Μαθ < 28 τότε
          Πλ <-- 1
     αλλιώς
          Πλ <-- 0
     Τέλος_αν
     Για λ από 2 μέχρι 16
          Διάβασε Μαθ
          Αν  Μαθ > ΜΑΧ τότε
               ΜΑΧ <-- Μαθ
               ΑΑΜΑΧ <-- λ
          Τέλος_αν
          Αν  Μαθ < ΜΙΝ τότε
               ΜΙΝ <-- Μαθ
               ΑΑΜΙΝ <-- λ
          Τέλος_αν
          Αν  Μαθ < 28 τότε
               Πλ <-- Πλ+1
          Τέλος_αν
          Πληθ <-- Πληθ+Μαθ
     Τέλος_επανάληψης
     Εμφάνισε Πληθ, ΑΑΜΙΝ, ΑΑΜΑΧ, Πλ
     Τέλος Γυμνάσιο

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου