Σάββατο, 23 Οκτωβρίου 2010

Άσκηση : Για+φρουρός (συνδυαστική)

Γράψτε αλγόριθμο που:
α)  διαβάζει τα ονοματεπώνυμα 22 τραγουδιστών και για καθένα
     από αυτούς τον τίτλο όλων των CD που έχουν τραγουδίσει
     (η είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί ως
     τίτλος CD το κενό διάστημα),
β) υπολογίζει και εμφανίζει:
     * το πλήθος των CD κάθε τραγουδιστή,
     * το ονοματεπώνυμο του τραγουδιστή με το μεγαλύτερο
        πλήθος CD.
     * το συνολικό πλήθος όλων των CD.
Παρατήρηση: Θεωρείστε ότι κάθε τραγουδιστής έχει τραγου-
δίσει σε τουλάχιστον ένα CD.

Λύση

        Αλγόριθμος CD
        MAX <-- -1
        Πλήθος <-- 0
        Για λ από 1 μέχρι 22
             Διάβασε ΟΝ
             ΤρCD <-- 0
            Αρχή_επανάληψης
                   Διάβασε Τιτλ
                   Αν Τιτλ < > '  ' τότε
                         ΤρCD <-- ΤρCD+1
                          Πλήθος <-- Πλήθος+1
                   Τέλος_αν
            Μέχρις_ότου Τιτλ = '  '
            Εμφάνισε ΤρCD
            Αν ΤρCD > ΜΑΧ τότε
                 ΜΑΧ <-- ΤρCD
                 ONMAX <-- ON
            Τέλος_αν
        Τέλος_επανάληψης
        Εμφάνισε ONMAX, Πλήθος
        Τέλος CD

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου