Δευτέρα, 25 Οκτωβρίου 2010

Δώστε την εκφώνηση της άσκησης

Δίνεται το παρακάτω πρόγραμμα σε ΓΛΩΣΣΑ
    ΠΡΟΓΡΑΜΜΑ ΑΣΚ
    ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: λ, Φ
           ΠΡΑΓΜΑΤΙΚΕΣ: Α[21], Χ, Υ, Ζ
    ΑΡΧΗ
           ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 21
                 ΔΙΑΒΑΣΕ Α[λ]
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           Χ <-- 0
           Φ <-- 0
           ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 21
                 ΑΝ Α[λ] > 0 ΤΟΤΕ
                      Φ <-- Φ+1
                 ΤΕΛΟΣ_ΑΝ
                 Χ <-- Χ+Α[λ]
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           Υ <-- Χ/21
           Ζ <-- 100*Φ/21
           ΓΡΑΨΕ Υ, Ζ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Ποιά είναι η εκφώνηση του προβλήματος που καλείται να
επιλύσει;



Απάντηση



Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) διαβάζει 21 πραγματικές τιμές και τις καταχωρεί σε
      κατάλληλο μονοδιάστατο πίνακα,
β)  υπολογίζει και εμφανίζει:
      * το μέσο όρο των τιμών του πίνακα,
      * το ποσοστό (%) των στοιχείων του πίνακα που
         είναι θετικά.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου