Τρίτη, 5 Οκτωβρίου 2010

Απλοποίηση

Απλοποιήστε το παρακάτω σύνολο εντολών
     Διάβασε α
     Αν (α > 0) Ή (α < 0) τότε
            β <-- ΑΛΗΘΗΣ ΚΑΙ (α < 100)
     αλλιώς
           β <-- (α = 0)
     Τέλος_αν
     Εμφάνισε β

Λύση

     Διάβασε α
     Αν α < > 0 τότε
            β <-- α < 100
     αλλιώς
           β <-- Αληθής
     Τέλος_αν
     Εμφάνισε β

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου