Τρίτη, 5 Ιουνίου 2012

Λύσεις Θεμάτων Πανελλαδικών Εξετάσεων Δ' τάξης Εσπερινού Γενικού Λυκείου 2012


ΘΕΜΑ Α


Α1. 

1.ΛΑΘΟΣ
2. ΛΑΘΟΣ
3.ΛΑΘΟΣ
4. ΛΑΘΟΣ
5. ΣΩΣΤΟ

Α2, Α3, Α4, Α5 :  Βλέπε λύσεις Ημερήσιου Γενικού Λυκείου 2012

ΘΕΜΑ Β
Βλέπε λύσεις Ημερήσιου Γενικού Λυκείου 2012

ΘΕΜΑ Γ
Βλέπε λύσεις Ημερήσιου Γενικού Λυκείου 2012

ΘΕΜΑ Δ

    Αλγόριθμος  ΘΔ
    Για Λ από 1 μέχρι 10
        Διάβασε ΟΝΟΜΑ[Λ]
    Τέλος_επανάληψης
    Για Μ από 1 μέχρι 10
        Για Λ από 1 μέχρι 12
              Διάβασε Π[Μ, Λ]
              Διάβασε Κ[Μ, Λ]
       Τέλος_επανάληψης
    Τέλος_επανάληψης
    Για Μ από 1 μέχρι 10
       Σ1 <-- 0
       Σ2 <-- 0
       Για Λ από 1 μέχρι 12
             Σ1 <-- Σ1+Π[Μ, Λ]
             Σ2 <-- Σ2+Κ[Μ, Λ]
       Τέλος_επανάληψης
       ΕΤΗΣΙΑ_Π[Μ] <-- Σ1
       ΕΤΗΣΙΑ_Κ[Μ] <-- Σ2
   Τέλος_επανάληψης
   Για Μ από 1 μέχρι 10
      Αν ΕΤΗΣΙΑ_Π[Μ] > ΕΤΗΣΙΑ_Κ[Μ] τότε
         ΕΣΟΔΑ[Μ] <-- (ΕΤΗΣΙΑ_Π[Μ]-ΕΤΗΣΙΑ_Κ[Μ])*0.55
      αλλιώς
         ΕΣΟΔΑ[Μ] <-- 0
      Τέλος_αν
   Τέλος_επανάληψης
   Για Μ από 2 μέχρι 10
       Για Λ από 10 μέχρι Μ με_βήμα -1
           Αν ΕΣΟΔΑ[Λ-1] < ΕΣΟΔΑ[Λ] τότε
               Βοηθ <-- ΕΣΟΔΑ[Λ-1]
               ΕΣΟΔΑ[Λ-1] <-- ΕΣΟΔΑ[Λ]
               ΕΣΟΔΑ[Λ] <-- Βοηθ
           Τέλος_αν
       Τέλος_επανάληψης
   Τέλος_επανάληψης
   Για Μ από 1 μέχρι 10
       Εμφάνισε ΕΣΟΔΑ[Μ]
   Τέλος_επανάληψης
   Τέλος ΘΔ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου