Δευτέρα, 13 Φεβρουαρίου 2012

Επεξεργασία τρισδιάστατου πίνακα

Γράψτε αλγόριθμο που γεμίζει τον ακέραιο πίνακα Α[2, 5, 4] με τις
τιμές 1, 2, 3, ..., 40.

Λύση

      Αλγόριθμος Ασκ
      χ <-- 1
      Για κ από 1 μέχρι 2
          Για λ από 1 μέχρι 5
               Για μ από 1 μέχρι 4
                     Α[κ, λ, μ] <--  χ
                     χ <-- χ+1
               Τέλος_επανάληψης
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Αποτελέσματα // Α //
      Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου