Παρασκευή, 17 Φεβρουαρίου 2012

Συγγραφή συνάρτησης

Γράψτε συνάρτηση η οποία δέχεται ως παράμετρο τον
πραγματικό πίνακα Α[12, 4, 2] και ελέγχει αν το άθροισμα
των στοιχείων που βρίσκονται σε βάθος 1 είναι ίσο με
το άθροισμα των στοιχείων που βρίσκονται σε βάθος 2.

Λύση

    ΣΥΝΑΡΤΗΣΗ ΙΣΑ(Α) : ΛΟΓΙΚΗ
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Α[12, 4, 2], Κ, Λ, Σ1, Σ2
    ΑΡΧΗ
          Σ1 <-- 0
          Σ2 <-- 0
          ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
              ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 4
                    Σ1 <-- Σ1+Α[Κ, Λ, 1]
                    Σ2 <-- Σ2+Α[Κ, Λ, 2]
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΑΝ Σ1 = Σ2 ΤΟΤΕ
                ΙΣΑ <-- ΑΛΗΘΗΣ
           ΑΛΛΙΩΣ
                ΙΣΑ <-- ΨΕΥΔΗΣ

           ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου