Σάββατο, 11 Αυγούστου 2012

Έλεγχος αλγοριθμικών κριτηρίων

Ποιο ή ποια αλγοριθμικά κριτήρια παραβιάζει το
παρακάτω σύνολο εντολών;
      Κ <-- 1
      Α <-- 0
      Όσο Κ <= 12 επανάλαβε
            Α <-- Α+1/(Κ-4)
            Αν Κ mod 12 = 0 τότε
                 Κ <-- Κ-10
            Τέλος_αν
            Κ <-- Κ+1
      Τέλος_επανάληψης
      Εμφάνισε Α

Λύση

    Παραβιάζονται:
    α) η καθοριστικότητα, γιατί όταν το Κ γίνει 4 η εντολή
        Α <-- Α+1/(Κ-4) δεν μπορεί να εκτελεστεί
    β) η περατότητα, γιατί το Κ δεν πρόκειται ποτέ να ξεπεράσει
        το 12 και η Όσο..επανάλαβε αποτελεί ατέρμων βρόχο (οι
        τιμές που παίρνει το Κ είναι 1, 2, ...., 12, 3, 4, ..., 12, 3, 4, ...., 12, κτλ)

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου