Πέμπτη, 6 Δεκεμβρίου 2012

Προσδιορισμός πλήθους επαναλήψεων

Θεωρήστε τις παρακάτω εμφωλευμένες δομές επανάληψης
   Για κ από Α μέχρι 12 μέ_βήμα Γ-1
       Για λ από 20 μέχρι Β με_βήμα -3
             Εμφάνισε 'ΤΕΣΤ'
       Τέλος_επανάληψης
   Τέλος_επανάληψης
Πόσες φορές τυπώνεται η λέξη ΤΕΣΤ σε καθεμιά από τις
παρακάτω περιπτώσεις;

1. Α = 12, Γ = 2, Β = 20
2. Α = 13, Γ = 20, Β = 5
3. Α = 15, Γ = 3, Β = 10
4. Α = 5, Γ = 1, Β = 2
5. Α = 3, Γ = 5, Β = 20
6. Α = 12, Γ = -3, Β = 30

Απάντηση
Πρέπει να βρούμε:
α) το πλήθος των επαναλήψεων της εξωτερικής Για
β) το πλήθος των επαναλήψεων της εσωτερικής Για
γ) να πολλαπλασιάσουμε τα δύο αποτελέσματα
Κατά συνέπεια:

1.   1 φορά (1 Χ 1 = 1)
2.   0 φορές (η εξωτερική Για δεν κάνει καμία επανάληψη)
3.   8 φορές    (2 Χ 4 = 8)
4.   άπειρες φορές (η εξωτερική Για είναι ατέρμων βρόχος)
5.   3 φορές (3 Χ 1 = 3)
6.   0 φορές ( 1 Χ 0 = 0)

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου