Πέμπτη, 19 Ιουλίου 2012

Συγγραφή συνάρτησης

Θεωρήστε την ακόλουθη δομή επανάληψης:
     Για κ από Α μέχρι Β με_βήμα Γ
          Εμφάνισε 'φορές'
     Τέλος_επανάληψης
Γράψτε συνάρτηση η οποία δέχεται ως παραμέτρους
τις ακέραιες τιμές Α, Β, Γ και επιστρέφει το χαρακτήρα:
* Μ, αν πραγματοποιείται τουλάχιστον μια επανάληψη,
* Τ, αν ο βρόχος είναι ατέρμων,
* Κ, αν δεν πραγματοποιείται καμία επανάληψη

Λύση


     ΣΥΝΑΡΤΗΣΗ ΕΛ(Α, Β, Γ) : ΧΑΡΑΚΤΗΡΑΣ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α, Β, Γ
     ΑΡΧΗ
           ΑΝ Γ = 0 ΤΟΤΕ
                 ΑΝ Α <= Β ΤΟΤΕ
                      ΕΛ <-- 'Τ'
                 ΑΛΛΙΩΣ
                      ΕΛ <-- 'Κ'
                 ΤΕΛΟΣ_ΑΝ
           ΑΛΛΙΩΣ_ΑΝ Γ > 0 ΤΟΤΕ
                  ΑΝ Α <= Β ΤΟΤΕ
                        ΕΛ <-- 'Μ'
                  ΑΛΛΙΩΣ
                        ΕΛ <-- 'Κ'
                  ΤΕΛΟΣ_ΑΝ
           ΑΛΛΙΩΣ   ! Γ < 0
                  ΑΝ Α >= Β ΤΟΤΕ
                        ΕΛ <-- 'Μ'
                  ΑΛΛΙΩΣ
                        ΕΛ <-- 'Κ'
                  ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου