Τετάρτη, 4 Ιουλίου 2012

Συγγραφή συνάρτησης

Γράψτε συνάρτηση η οποία δέχεται ως παράμετρο έναν
πραγματικό πίνακα Α[14, 14] και υπολογίζει πόσα
στοιχεία της 1ης κυρίας διαγωνίου έχουν τιμή μεγαλύτερη
από το μέσο όρο του πίνακα.

Απάντηση

     ΣΥΝΑΡΤΗΣΗ ΠΟΣΑ(Α) : ΑΚΕΡΑΙΑ
     ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Α[14, 14], Σ, ΜΟ
          ΑΚΕΡΑΙΕΣ:  ΠΛΗΘ, Κ, Λ
     ΑΡΧΗ
           Σ <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 14
               ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 14
                    Σ <-- Σ+Α[Κ, Λ]
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΜΟ <-- Σ/196
           ΠΛΗΘ <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 14
                ΑΝ Α[Κ, Κ] > ΜΟ ΤΟΤΕ
                      ΠΛΗΘ <-- ΠΛΗΘ+1
                ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΠΟΣΑ <-- ΠΛΗΘ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου