Πέμπτη, 3 Νοεμβρίου 2011

Απλοποίηση

Ξαναγράψτε το παρακάτω σύνολο εντολών με μια μόνο Για
     Α <-- 0
     Για κ από 1 μέχρι 120 με_βήμα 3
         Α <-- Α+κ
         Για λ από 1 μέχρι 32 με_βήμα 5
                Αν λ = 11 τότε
                      Α <-- Α+λ
                Τέλος_αν
                Για μ από 1 μέχρι 43 με_βήμα 7
                       Αν μ = 29 τότε
                            Α <-- Α+μ
                       Τέλος_αν
                Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης


Λύση


     Α <-- 0
     Για κ από μέχρι 120 με_βήμα 3
         Α <-- Α+κ+11+(7*29)
     Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου