Παρασκευή, 18 Νοεμβρίου 2011

Άσκηση : Φρουρός

Γράψτε αλγόριθμο που :
α) διαβάζει το πλήθος των χαρακτήρων που περιλαμβάνουν
    οι εκθέσεις κάποιων μαθητών (η είσοδος δεδομένων
    ολοκληρώνεται μόλις δοθεί μια μη θετική τιμή),
β) υπολογίζει και εμφανίζει:
    * το συνολικό πλήθος των εκθέσεων,
    * το μέσο όρο πλήθους χαρακτήρων ανά έκθεση,
    * τον αύξοντα αριθμό της συντομότερης έκθεσης.
Παρατήρηση : Θεωρείστε ότι καμιά έκθεση δεν είχε
περισσότερους από 1200 χαρακτήρες.


Λύση


     Αλγόριθμος Εκθέσεις
     Πληθ <-- 0
     σ <-- 0
     Μικ <-- 1201
     Αρχή_επανάληψης
           Διάβασε Χαρ
           Αν Χαρ > 0 τότε
                Πληθ <-- Πληθ+1
                σ <-- σ+Χαρ
                Αν Χαρ < Μικ τότε
                     Μικ <-- Χαρ
                     ΘΜικ <-- Πληθ
                Τέλος_αν
           Τέλος_αν
     Μέχρις_ότου Χαρ <= 0
     Αν Πληθ > 0 τότε
           ΜΟ <-- σ/Πληθ
           Εμφάνισε Πληθ, ΜΟ, ΘΜικ
     αλλιώς
           Εμφάνισε 'Δε δόθηκαν καθόλου δεδομένα!'
     Τέλος_αν
     Τέλος Εκθέσεις

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου