Σάββατο, 23 Μαρτίου 2013

Απλοποίηση

Απλοποιήστε το παρακάτω σύνολο εντολών και
ξαναγράψτε το με ισοδύναμο τρόπο
    Για κ από 10 μέχρι 10 με_βήμα 7
         Για λ από κ+1 μέχρι 2*κ με_βήμα κ-4
                 Αν κ+λ > 22 τότε
                       Εμφάνισε (κ-λ)^2
                 αλλιώς
                       Εμφάνισε 3*κ-λ
                       Εμφάνισε (κ-λ)^2
                 Τέλος_αν
         Τέλος_επανάληψης
    Τέλος_επανάληψης
    Εμφάνισε κ

Λύση

         Για λ από 11 μέχρι 20 με_βήμα 6
                 Αν λ <= 12 τότε                   
                       Εμφάνισε 30-λ                     
                 Τέλος_αν
                 Εμφάνισε (10-λ)^2
         Τέλος_επανάληψης
         Εμφάνισε 17

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου