Παρασκευή, 2 Σεπτεμβρίου 2011

Βήμα-βήμα εκτέλεση (Για..από..μέχρι)

Τι εμφανίζει το παρακάτω σύνολο εντολών στη μονάδα
εξόδου;
       Για κ από 10 μέχρι 17 με_βήμα 3
             Αν Κ mod 4 = 0 τότε
                  Εμφάνισε (Κ+31) mod 27,  Κ > 15
             αλλιώς
                  Εμφάνισε (Κ-10)*1000+1, Κ^2 > 200
             Τέλος_αν
       Τέλος_επανάληψης
       Εμφάνισε Κ

Λύση

       κ = 10
             Αφού (Κ mod 4 = 0) = (10 mod 4 = 0) = (2 = 0) =
                       Ψευδής
                    επειδή (Κ-10)*1000+1 = (10-10)*1000+1 =
                                0*1000+1 = 0+1 = 1,
                                Κ^2 > 200 = 10^2 > 200 = 100 > 200 =
                                Ψευδής, η Εμφάνισε τυπώνει:
                                          1        Ψευδής
       κ = 13
             Αφού (Κ mod 4 = 0) = (13 mod 4 = 0) = (1 = 0) =
                       Ψευδής
                    επειδή (Κ-10)*1000+1 = (13-10)*1000+1 =
                                3*1000+1 = 3000+1 = 3001,
                                Κ^2 > 200 = 13^2 > 200 = 169 > 200 =
                                Ψευδής, η Εμφάνισε τυπώνει:
                                          3001        Ψευδής
       κ = 16
             Αφού (Κ mod 4 = 0) = (16 mod 4 = 0) = (0 = 0) =
                       Αληθής
                    επειδή  (Κ+31) mod 27 = (16+31) mod 27 =
                                 47 mod 27 = 20 ,
                                 Κ > 15 = 16 > 15 = Αληθής, η Εμφάνισε 
                                 τυπώνει:
                                          20        Αληθής
       Η Για τερματίζεται με κ = 19.
       Η Εμφάνισε τυπώνει : 19

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου