Πέμπτη, 8 Σεπτεμβρίου 2011

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών με ισοδύναμο
τρόπο, χρησιμοποιώντας μόνο μια εντολή Αν..τότε
          Αν  Απ = 'ΝΑΙ' τότε
                Αμ <-- 100*Χ+56
          αλλιώς
                Αμ <-- 100*Χ
          Τέλος_αν

Λύση

          Αμ <-- 100*Χ
          Αν  Απ = 'ΝΑΙ' τότε
                Αμ <-- Αμ+56
          Τέλος_αν

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου