Σάββατο, 24 Σεπτεμβρίου 2011

Μονοδιάστατος πίνακας

Γράψτε αλγόριθμο που :
α) διαβάζει ένα θετικό τετραψήφιο ακέραιο,
β) να κωδικοποιεί τα ψηφία του χρησιμοποιώντας τα
    πρώτα 10 γράμματα του ελληνικού αλφαβήτου
    (0 - α, 1 - β, 2 - γ, κτλ)
γ) να εμφανίζει στην οθόνη την κωδικοποιημένη
    μορφή του αριθμού.
Παρατήρηση : Ο αλγόριθμος πρέπει να διασφαλίζει
την εγκυρότητα των εισερχόμενων δεδομένων

Λύση

       Αλγόριθμος Ασκ
       Αρχή_επανάληψης
             Διάβασε Αριθμ
       Μέχρις_ότου  (Αριθμ >= 1000) ΚΑΙ (Αριθμ <= 9999)
       Για κ από 1 μέχρι 4
             Ψ[κ] <-- Αριθμ MOD 10
             Αριθμ <-- Αριθμ DIV 10
       Τέλος_επανάληψης
       Για κ από 1 μέχρι 4
             Αν Ψ[κ] = 0 τότε
                  Εμφάνισε  'α'
             αλλιώς_αν Ψ[κ] = 1 τότε
                  Εμφάνισε 'β'
             αλλιώς_αν Ψ[κ] = 2 τότε
                  Εμφάνισε 'γ'
             αλλιώς_αν Ψ[κ] = 3 τότε
                  Εμφάνισε 'δ'
             αλλιώς_αν Ψ[κ] = 4 τότε
                  Εμφάνισε 'ε'
             αλλιώς_αν Ψ[κ] = 5  τότε
                  Εμφάνισε 'ζ'
             αλλιώς_αν Ψ[κ] = 6 τότε
                  Εμφάνισε 'η'
             αλλιώς_αν Ψ[κ] = 7 τότε
                  Εμφάνισε 'θ'
             αλλιώς_αν Ψ[κ] = 8 τότε
                  Εμφάνισε 'ι'
             αλλιώς
                  Εμφάνισε 'κ'
             Τέλος_αν
       Τέλος_επανάληψης 
       Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου