Παρασκευή, 23 Σεπτεμβρίου 2011

Φρουρός

Γράψτε αλγόριθμο που:
α) διαβάζει δυάδες αριθμών (η είσοδος τερματίζεται μόλις
    μια τουλάχιστον από τις τιμές εισόδου είναι μηδέν),
β) υπολογίζει και εμφανίζει:
    * το μέσο όρο τους,
    * τη μεγαλύτερη τιμή τους,
    * τη μικρότερη τιμή τους.
Παρατήρηση : Θεωρείστε ότι οι τιμές εισόδου είναι διαφορετικές
μεταξύ τους.

Λύση

      Αλγόριθμος Δυάδες
      Αρχή_επανάληψης
            Διάβασε Α, Β
            Αν (Α < > 0) ΚΑΙ (Β < > 0) τότε
                 ΜΟ <-- (Α+Β)/2
                 Αν Α > Β τότε
                        ΜΑΧ <-- Α
                        ΜΙΝ <-- Β
                 αλλιώς
                        ΜΑΧ <-- Β
                        ΜΙΝ <-- Α
                 Τέλος_αν
                 Εμφάνισε ΜΑΧ, ΜΙΝ, ΜΟ
            Τέλος_αν
      Μέχρις_ότου (Α = 0) Ή (Β = 0)
      Τέλος Δυάδες

1 σχόλιο:

  1. Όταν αναφέρεται στην εκφώνηση μέσο όρο,μεγαλύτερη και μικρότερη τιμή εννοείται εκ των δύο αριθμών σωστά?

    ΑπάντησηΔιαγραφή