Παρασκευή, 16 Σεπτεμβρίου 2011

Φρουρός

Γράψτε αλγόριθμο που :
α) διαβάζει το εμβαδόν σε τετραγωνικά μέτρα κάποιων
    αγροτεμαχίων (η είσοδος δεδομένων ολοκληρώνεται
    μόλις δοθεί  μια μη θετική τιμή),
β) υπολογίζει και εμφανίζει τον αύξοντα αριθμό του
    μεγαλύτερου αγροτεμαχίου.

Λύση

      Αλγόριθμος ΑΓΡΟ
      Μεγ <-- -100
      Πληθ <-- 0
      Αρχή_επανάληψης
            Διάβασε Εμβ
            Αν Εμβ > 0 τότε
                 Πληθ <-- Πληθ+1
                 Αν Εμβ > Μεγ τότε
                      Μεγ <-- Εμβ
                      ΑΑΜεγ <-- Πληθ
                 Τέλος_αν
            Τέλος_αν
      Μέχρις_ότου Εμβ <= 0
      Αν Μεγ > 0 τότε
           Εμφάνισε ΑΑΜεγ
      αλλιώς
           Εμφάνισε 'Λάθος δεδομένα'
      Τέλος_αν
      Τέλος ΑΓΡΟ

1 σχόλιο:

  1. 1)Αύξοντα αριθμό του αγροτεμαχίου από τα μέγιστα ή γενικά?
    2)Δε θα ήταν καλύτερο να γίνει με Όσο?Υπάρχει κάποιος λόγος που χρησιμοποιείς περισσότερο την μέχρις ότου?Απλά πληροφοριακά ρωτάω.

    ΑπάντησηΔιαγραφή