Τετάρτη, 14 Δεκεμβρίου 2011

Συγγραφή διαδικασίας

Θεωρείστε τους ακόλουυθους πίνακες:
* ΣΥΓΚ[200], που περιέχει τα ονόματα 200 μουσικών
   συγκροτημάτων,
* ΕΘΝ[200], που περιέχει τη χώρα προέλευσης των
  συγκροτημάτων αυτών.
Γράψτε διαδικασία που δέχεται ως παραμέτρους τους
δύο παραπάνω πίνακες και :
α) υπολογίζει το συνολικό πλήθος των συγκροτημάτων
    που προέρχονται από την ΕΛΛΑΔΑ,
β) καταχωρεί σε πίνακα τα ονόματα των συγκροτημάτων
    αυτών.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΜΟΥΣΙΚΗ(ΣΥΓΚ, ΕΘΝ, Ελλ, ΣυγκΕλλ)
     ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Ελλ, Κ
          ΧΑΡΑΚΤΗΡΕΣ: ΣΥΓΚ[200], ΕΘΝ[200], ΣυγκΕλλ[200]
     ΑΡΧΗ
           Ελλ <-- 0
           ΓΙΑ Κ ΑΠΌ 1 ΜΕΧΡΙ 200
               ΑΝ ΕΘΝ[Κ] = 'ΕΛΛΑΔΑ' ΤΟΤΕ
                    Ελλ <-- Ελλ+1
                    ΣυγκΕλλ[Ελλ] <-- ΣΥΓΚ[Κ]
               ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου