Σάββατο, 24 Δεκεμβρίου 2011

Εμφωλευμένες δομές επανάληψης

Γράψτε αλγόριθμο που:
α) διαβάζει τις μηνιαίες εισπράξεις των τελευταίων 10 ετών
    για 15 επιχειρήσεις του Ηρακλείου,
β) υπολογίζει και εμφανίζει:
    * τις ετήσιες εισπράξεις κάθε επιχείρησης, για κάθε χρόνο
       ξεχωριστά,
    * τη μέση ετήσια είσπραξη για κάθε επιχείρηση ξεχωριστά,
    * τη μεγαλύτερη μηνιαία είσπραξη, τον αύξοντα αριθμό
       (1- 15) της επιχείρησης που την πραγματοποίησε και
       πότε συνέβη αυτό (αύξοντα αριθμό μήνα, αύξοντα αριθμό
       έτους).

Λύση

       Αλγόριθμος Επιχειρ
       Μεγ <-- -100
       Για κ από 1 μέχρι 15
            Αθρ <-- 0
            Για λ από 1 μέχρι 10
                  σ <-- 0
                  Για μ από 1 μέχρι 12
                       Διάβασε Μην
                       Αν Μην > Μεγ τότε
                             Μην <-- Μεγ
                             ΑΑΕπ <-- κ
                             ΑΑΧρ <-- λ
                             ΑΑΜην <-- μ
                       Τέλος_αν
                       σ <-- σ+Μην
                  Τέλος_επανάληψης
                  Εμφάνισε σ
                  Αθρ <-- Αθρ+σ
            Τέλος_επανάληψης
            ΜΟ <-- Αθρ/10
            Εμφάνισε ΜΟ
       Τέλος_επανάληψης
       Εμφάνισε Μεγ, ΑΑΕπ, ΑΑΧρ, ΑΑΜην
       Τέλος Επιχειρ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου