Σάββατο, 31 Δεκεμβρίου 2011

Εξαφανίστε την GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε να
ακολουθεί τις αρχές του δομημένου προγραμματισμού
     Α <-- 0
     Κ <-- 100
10 : ΑΝ Κ < 0 ΤΟΤΕ GOTO 60
       Λ <-- 4
20 : ΑΝ Λ > 80 ΤΟΤΕ GOTO 70
       ΓΡΑΨΕ Κ^2+Λ^2
       Λ <-- Λ+4
       GOTO 20
       K <-- K-1
       GOTO 10
       ΓΡΑΨΕ 'ΑΝΤΙΟ 2011'

Λύση

     Α <-- 0
     Κ <-- 100
     ΟΣΟ Κ >= 0 ΕΠΑΝΑΛΑΒΕ
          Λ <-- 4
          ΟΣΟ Λ <= 80 ΕΠΑΝΑΛΑΒΕ
               ΓΡΑΨΕ Κ^2+Λ^2
               Λ <-- Λ+4
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          K <-- K-1
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΓΡΑΨΕ 'ΑΝΤΙΟ 2011'

      

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου