Τρίτη, 3 Ιανουαρίου 2012

Αναζήτηση

Γράψτε αλγόριθμο που δέχεται ως δεδομένα τους
ακέραιους πίνακες Α[10, 12], Β [13, 18] και αναζητά
κάθε στοιχείο του Α μέσα στον Β, εμφανίζοντας
κατάλληλα ενημερωτικά μηνύματα.

Λύση

      Αλγόριθμος ΠΙΝ
      Δεδομένα // Α, Β //
      Για κ από 1 μέχρι 10
         Για λ από 1 μέχρι 12
                Βρεθ <-- Ψευδής
                ρ <-- 1
                Όσο (ρ <= 13) ΚΑΙ (Βρεθ = Ψευδής) επανάλαβε
                      μ <-- 1
                      Όσο (μ <= 18) ΚΑΙ (Βρεθ = Ψευδής) επανάλαβε
                           Αν Β[ρ, μ] = Α[κ, λ]  τότε
                                 Βρεθ <-- Αληθής
                                 Θρ <-- ρ
                                 Θμ <-- μ
                           αλλιώς
                                 μ <-- μ+1
                           Τέλος_αν
                      Τέλος_επανάληψης
                      Αν Βρεθ = Ψευδής τότε
                            ρ <-- ρ+1
                      Τέλος_αν
                Τέλος_επανάληψης
                Αν Βρεθ = Αληθής τότε
                      Εμφάνισε 'Το στοιχείο ', Α[κ, λ], ' βρέθηκε στη'
                      Εμφάνισε 'γραμμή ', Θρ, 'και στη στήλη ', Θμ
                αλλιώς
                      Εμφάνισε 'Το στοιχείο ', Α[κ, λ], ' δεν βρέθηκε!!!'
                Τέλος_αν
         Τέλος_επανάληψης
      Τέλος_επανάληψης
      Τέλος ΠΙΝ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου