Δευτέρα, 30 Ιανουαρίου 2012

Συγχώνευση τρισδιάστατων πινάκων

Γράψτε αλγόριθμο που συγχωνεύει δύο δοσμένους
αλφαριθμητικούς πίνακες Β[12, 3, 5] και Γ[12, 3, 4]
σε έναν αλφαριθμητικό πίνακα Α[12, 3, 9].

Λύση

      Αλγόριθμος ΑΣΚ
      Δεδομένα // Β, Γ //
      Για  κ από 1 μέχρι 12
          Για λ από 1 μέχρι 3
               Για μ από 1 μέχρι 5
                    Α[κ, λ, μ] <-- Β[κ, λ, μ]
               Τέλος_επανάληψης
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Για  κ από μέχρι 12
          Για λ από μέχρι 3
               Για μ από μέχρι 4
                    Α[κ, λ, μ+5] <-- Γ[κ, λ, μ]
               Τέλος_επανάληψης
          Τέλος_επανάληψης
      Τέλος_επανάληψης   
      Αποτελέσματα // Α //
      Τέλος ΑΣΚ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου