Σάββατο, 7 Ιανουαρίου 2012

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών χρησιμοποιώντας
την εντολή Μέχρις_ότου
       Για κ από Χ μέχρι Υ με_βήμα 2
             Εμφάνισε κ
       Τέλος_επανάληψης


Λύση


    Αν Χ <= Υ τότε
         κ <-- Χ
         Αρχή_επανάληψης
               Εμφάνισε κ
               κ <-- κ+2
         Μέχρις_ότου κ > Υ
    Τέλος_αν

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου