Δευτέρα, 30 Ιανουαρίου 2012

Διαχωρισμός τρισδιάστατου πίνακα

Δίνεται πίνακας Α[10, 4, 12] ακεραίου τύπου. Γράψτε αλγόριθμο
που διαχωρίζει τον Α σε δύο άλλους ακέραιους πίνακες
Β[10, 4, 6] και Γ[10, 4, 6].

Λύση

      Αλγόριθμος ΑΣΚ
      Δεδομένα // Α //
      Για Κ από 1 μέχρι 10
          Για Λ από 1 μέχρι 4
              Για Μ από 1 μέχρι 6
                     Β[Κ, Λ, Μ] <-- Α[Κ, Λ, Μ]
                     Γ[Κ, Λ, Μ] <-- Α[Κ, Λ, Μ+6]
              Τέλος_επανάληψης
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Αποτελέσματα // Β. Γ //
      Τέλος ΑΣΚ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου