Δευτέρα, 9 Ιανουαρίου 2012

Αναζήτηση σε τρισδιάστατο

Γράψτε αλγόριθμο που αναζητά την τιμή Χ μέσα στον
πίνακα Α[12, 45, 3].

Λύση

    Αλγόριθμος Αναζ
    Δεδομένα // Α, Χ //
    βρεθ <-- Ψευδής
    θκ <-- 0
    θλ <-- 0
    θμ <-- 0
    κ <-- 1
    Όσο (κ <= 12) ΚΑΙ (βρεθ = Ψευδής) επανάλαβε
        λ <-- 1
        Όσο (λ <= 45) ΚΑΙ (βρεθ = Ψευδής) επανάλαβε
             μ <-- 1
             Όσο (μ <= 3) ΚΑΙ (βρεθ = Ψευδής) επανάλαβε
                  Αν Α[κ, λ, μ] = Χ τότε
                        βρεθ <-- Αληθής
                        θκ <-- κ
                        θλ <-- λ
                        θμ <-- μ
                  αλλιώς
                       μ <-- μ+1
                  Τέλος_αν
             Τέλος_επανάληψης
             Αν βρεθ = Ψευδής τότε
                  λ <-- λ+1
             Τέλος_αν
        Τέλος_επανάληψης
         Αν βρεθ = Ψευδής τότε
              κ <-- κ+1
         Τέλος_αν
    Τέλος_επανάληψης
     Αποτελέσματα // βρεθ, θκ, θλ, θμ //
    Τέλος Αναζ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου