Τετάρτη, 25 Ιανουαρίου 2012

Άσκηση σε τρισδιάστατο πίνακα

Γράψτε αλγόριθμο που υπολογίζει το ποσοστό (%) των
μη μηδενικών στοιχείων στον ακέραιο πίνακα Α[11, 2, 34].

Λύση

    Αλγόριθμος Ασκ
    Δεδομένα // Α //
    φ <-- 0
    Για κ από 1 μέχρι 11
        Για λ από 1 μέχρι 2
              Για μ από 1 μέχρι 34
                  Αν Α[κ, λ, μ] < > 0 τότε
                        φ <-- φ+1
                  Τέλος_αν
              Τέλος_επανάληψης
        Τέλος_επανάληψης
    Τέλος_επανάληψης
     ΠΟΣ <-- 100*φ/(11*2*34)
    Αποτελέσματα // ΠΟΣ //
    Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου