Πέμπτη, 12 Ιανουαρίου 2012

Επεξεργασία τριδσδιάστατου πίνακα

Δίνεται ακέραιος πίνακας Α[11, 13, 15]. Γράψτε αλγόριθμο
που υπολογίζει:
α) πόσα στοιχεία της 1ης γραμμής είναι θετικά,
β) το μέσο όρο των στοιχείων που ανήκουν στην 3η γραμμή
    και την 2η στήλη,
γ) το γινόμενο όλων των στοιχείων του πίνακα.

Λύση

    Αλγόριθμος Ασκ
    Δεδομένα // Α //
    θετ <-- 0
    Για λ από 1 μέχρι 13
        Για μ από 1 μέχρι 15
             Αν Α[1, λ, μ] > 0 τότε
                  θετ <-- θετ+1
             Τέλος_αν
        Τέλος_επανάληψης
    Τέλος_επανάληψης
    σ <-- 0
    Για μ από 1 μέχρι 15
         σ <-- σ+Α[3, 2, μ]
    Τέλος_επανάληψης
    ΜΟ <-- σ/15
    Γιν <-- 1
    Για κ από 1 μέχρι 11
      Για λ από 1 μέχρι 13
        Για μ από 1 μέχρι 15
             Γιν <-- Γιν*Α[κ, λ, μ]
        Τέλος_επανάληψης

      Τέλος_επανάληψης
    Τέλος_επανάληψης 
    Αποτελέσματα // θετ, ΜΟ, Γιν //
    Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου