Πέμπτη, 12 Ιανουαρίου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παράμετρο έναν
πραγματικό πίνακα Α[12,13] και υπολογίζει:
* την ελάχιστη τιμή του,
* τις συντεταγμένες (αριθμός γραμμής και στήλης)
   που καταλαμβάνει η τιμή αυτή μέσα στον πίνακα.

Λύση

   ΔΙΑΔΙΚΑΣΙΑ ΜΙΚΠΙΝ(Α, ΜΙΝ, ΘΚ, ΘΛ)
   ΜΕΤΑΒΛΗΤΕΣ
         ΠΡΑΓΜΑΤΙΚΕΣ: Α[12, 13], ΜΙΝ
         ΑΚΕΡΑΙΕΣ: Κ, Λ, ΘΚ, ΘΛ
   ΑΡΧΗ
         ΜΙΝ <-- Α[1, 1]
         ΘΚ <-- 1
         ΘΛ <-- 1
         ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
                ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 13
                      ΑΝ Α[Κ, Λ] < ΜΙΝ ΤΟΤΕ
                            ΜΙΝ <-- Α[Κ, Λ]
                            ΘΚ <-- Κ
                            ΘΛ <-- Λ
                      ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου