Δευτέρα, 16 Ιανουαρίου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παράμετρο έναν
τρισδιάστατο ακέραιο πίνακα Α[3, 4, 5] και υπολογίζει
τη συχνότητα εμφάνισης των αριθμών -3, -2, -1, ..., 12
μέσα στον πίνακα αυτό.

Λύση
 
    ΔΙΑΔΙΚΑΣΙΑ ΕΠΕΞ(Α, ΣΥΧΝ)
    ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α[3, 4, 5], Κ, Λ, Μ, ΣΥΧΝ[16], ΤΙΜΗ, ΘΕΣΗ
    ΑΡΧΗ
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 16
                 ΣΥΧΝ[Κ] <-- 0
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΙΑ Κ ΑΠΟ ΜΕΧΡΙ 3
               ΓΙΑ Λ ΑΠΟ ΜΕΧΡΙ 4
                  ΓΙΑ Μ ΑΠΟ ΜΕΧΡΙ 5
                        ΤΙΜΗ <-- Α[Κ, Λ, Μ]
                        ΑΝ (ΤΙΜΗ >= -3) ΚΑΙ (ΤΙΜΗ <= 12) ΤΟΤΕ
                              ΘΕΣΗ <-- ΤΙΜΗ+4
                              ΣΥΧΝ[ΘΕΣΗ] <-- ΣΥΧΝ[ΘΕΣΗ]+1
                        ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου