Τετάρτη, 7 Δεκεμβρίου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παράμετρο έναν
ακέραιο πίνακα Α[200] και εξετάζει αν ισχύει η
ιδιότητα :
       Α[Κ] <= Α[Κ+2] <= Α[Κ+1]
για Κ = 1, 2, ..., 198

Λύση

      ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ(Α) : ΛΟΓΙΚΗ
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Α[200], Κ
             ΛΟΓΙΚΕΣ : ΑΠ
      ΑΡΧΗ
             ΑΠ <-- ΑΛΗΘΗΣ
             Κ <-- 1
             ΟΣΟ (Κ <= 198) ΚΑΙ (ΑΠ = ΑΛΗΘΗΣ) ΕΠΑΝΑΛΑΒΕ
                   ΑΝ (Α[Κ] > Α[Κ+2]) Ή (Α[Κ+2] > Α[Κ+1) ΤΟΤΕ
                          ΑΠ <-- ΨΕΥΔΗΣ
                   ΑΛΛΙΩΣ
                          Κ <-- Κ+1
                   ΤΕΛΟΣ_ΑΝ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΕΛΕΓΧΟΣ <-- ΑΠ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου