Σάββατο, 3 Δεκεμβρίου 2011

Άσκηση : Εμφωλευμένα Για+βοηθητικός πίνακας

Θέλετε να σχεδιάσετε πάνω σε μια κόλλα χαρτί  τέσσερα
τετράγωνα. Γράψτε αλγόριθμο που εμφανίζει όλους τους
δυνατούς συνδυασμούς χρωμάτων με τους οποίους μπορείτε να
τα σχεδιάσετε.Τα χρώματα που μπορείτε να χρησιμοποιήσετε
για το καθένα είναι μπλε, κόκκινο, πράσινο και κίτρινο.

Λύση

     Αλγόριθμος Ασκ
     Χ[1] <-- 'μπλε'
     Χ[2] <-- 'κόκκινο'
     Χ[3] <-- 'πράσινο'
     Χ[4] <-- 'κίτρινο'
     Για κ από 1 μέχρι 4
         Για λ από 1 μέχρι 4
              Για μ από 1 μέχρι 4
                   Για ρ από 1 μέχρι 4
                       Εμφάνισε Χ[κ], Χ[λ], Χ[μ], Χ[ρ]
                   Τέλος_επανάληψης
              Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου