Τρίτη, 24 Μαρτίου 2015

Συγγραφή διαδικασίας

Θεωρήστε τον πίνακα ΟΝ[30] που περιέχει 
τα ονοματεπώνυμα των μαθητών μιας τάξης.
Αν κάθε μαθητής κάνει μια ακριβώς χειραψία
με καθένα από τους συμμαθητές του, γράψτε 
διαδικασία που εμφανίζει ποιος έκανε χειραψία
με ποιον.

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΧΕΙΡΑΨΙΑ(ΟΝ)
ΜΕΤΑΒΛΗΤΕΣ
      ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[30]
      ΑΚΕΡΑΙΕΣ: Κ, Λ
ΑΡΧΗ
       ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 30
            ΓΙΑ Λ ΑΠΟ Κ+1 ΜΕΧΡΙ 30
                  ΓΡΑΨΕ ΟΝ[Κ], 'με', ΟΝ[Λ]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου