Σάββατο, 7 Μαρτίου 2015

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών
μόνο με Αν..τότε στη θέση της Αν..τότε..αλλιώς_αν
    Αν Α > Β τότε
        Εμφάνισε Α-Β
    αλλιώς_αν  Α mod 2 = 0 τότε
        Εμφάνισε Α+Β
    αλλιώς
        Εμφάνισε Α*Β
    Τέλος_αν

Λύση

   Αν Α > Β τότε
        Εμφάνισε Α-Β
   Τέλος_αν
   Αν  (Α <=  Β) ΚΑΙ (Α mod 2 = 0) τότε
        Εμφάνισε Α+Β
   Τέλος_αν
   Αν (Α <=  Β) ΚΑΙ (Α mod 2 < > 0) τότε
        Εμφάνισε Α*Β
   Τέλος_αν


Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου